Registrati |  Password persa?
 
Menu principale
Utenti online
7 utente(i) online (1 utente(i) in Forum)

Iscritti: 0
Utenti anonimi: 7

Altro...
Nuovi utenti
Giucal 20/10/2013
Corvinus 10/11/2011
Luis 29/3/2011
Landolfo 1/7/2008
bilbo80 28/4/2008
fefello 24/2/2008
tom 7/12/2007
robyt 20/9/2007
diavolino 2/8/2007
alejandro 28/4/2007
Indice del forum LDRWEB.net - consulting & software development
   pgDesigner
     [HowTo] pgDesigner + Ubuntu-6.06.1-i386 (Italiano/English/Polski)
Registrati per inviare messaggi

Ad albero | I pi nuovi prima Discussione precedente | Discussione successiva | In fondo
Autore Discussione
pe3no
Inviato il: 9/10/2006 1:01
Matricola
Registrao: 5/8/2006
Da:
Messaggi: 17
[HowTo] pgDesigner + Ubuntu-6.06.1-i386 (Italiano/English/Polski)
English version of this HowTo will be available at: http://sourceforge.net/forum/forum.php?forum_id=532137
Polska wersja tego HowTo zostanie umieszczona na : http://forum.ubuntu.pl/viewforum.php?f=44




********************************************************************************
*                                                                              *
*   p g D e s i g n e r -  OPEN SOURCE Datamodel designer for PostgreSQL  !!!  *
*                                                                              *
********************************************************************************




Screenshots http://sourceforge.net/project/screenshots.php?group_id=158060
Il sito del progetto http://pgdesigner.sourceforge.net/en/index.html
L'ultima versione del programma http://sourceforge.net/projects/pgdesigner
Il Forum inglese http://sourceforge.net/forum/?group_id=158060
Il Forum italiano http://www.ldrweb.net/modules/newbb/viewforum.php?forum=10



Ciao,
ho preparato una guida per l'installazione di pgDesigner su Ubuntu-6.06.1-i386


1. Prima di tutto bisogna fare una copia del file "sources.list" originale:
$ sudo cp /etc/apt/sources.list /etc/apt/sources.list.bak


2. Aprire il file:
$ sudo gedit /etc/apt/sources.list


3. Eliminare tutti i caratteri "#" posizionati davanti alla stringa "deb". Salvare i cambiamenti e chiudere l'editor.


4. Eseguire l'aggiornamento:
$ sudo apt-get update


5. Scaricare la versione aggiornata del progetto pgDesigner (*.bz2) dal sito ufficiale nella vostra home directory:
http://sourceforge.net/project/showfiles.php?group_id=158060


6. Controllare la versione di Gambas necessaria alla compilazione di pgDesigner:
- Visitare il sito http://sourceforge.net/projects/pgdesigner
- Fare un click sul link del pgDesigner piu' recente - "pgDesigner X.X.XX Released"
- In fondo all'elenco delle variazioni dell'ultima release del programma, contenute nel file ChangeLog, e' indicata la versione Gambas con cui e' compilato pgDesigner - "Program compiled with version Y.Y.YY of Gambas"


**************************************************************************************************
*                                                                                                *
*  Attenzione - i comandi dovranno essere opportunamente modificati per le versioni successive   *
*                                                                                                *
**************************************************************************************************



7. Scaricare Gambas da http://gambas.sourceforge.net/ nella vostra home directory.


8. Posizionarsi nella home directory:
$ cd $HOME


9. Installare i pacchetti necessari a Gambas e per la compilazione di pgDesigner - 314 MB circa:
$ sudo apt-get install build-essential libsdl-gfx1.2-dev libsdl-ttf2.0-dev libomniorb4-dev libldap2-dev libcurl3-gnutls-dev libpq-dev libgtkhtml2-dev kdepim-dev unixodbc-dev libdbd-sqlite libsqlite0-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsqlite3-dev libmysqlclient15-dev


10. Decomprimere i sorgenti di pgDesigner (sostituire "X.X.XX" con la versione corrente del programma):
$ tar xjvf pgDesigner-X.X.XX.tar.bz2


11. Decomprimere il file con i sorgenti di Gambas (sostituire "Y-Y.Y.YY" con la versione indicata nel ChangeLog):
$ tar xjvf gambasY-Y.Y.YY.tar.bz2


12. Posizionarsi nella directory dove e' stato decompresso Gambas:
$ cd gambasY-Y.Y.YY


13. Lanciare il comando per la preparazione della configurazione:
$ sudo ./configure -C


14. Compilare Gambas:
$ sudo make


15. Installare Gambas:
$ sudo make install


16. Creare un link simbolico a pgDesigner:
$ sudo ln -s $HOME/pgDesigner/pgDesigner.gambas /usr/bin/pgdesigner


17. Modificare i diritti della directory .kde - per sbloccare dcopserver:
$ sudo chmod -R 777 /home/`whoami`/.kde/


18. Per lanciare pgDesigner, aprire una sessione di terminale:
$ pgdesigner


Cordiali saluti~~Piotrek~~pe3no.


P.S. Vorrei ringraziare a Luigi - per la pazienza durante il controllo linguistico :) :) :)
... ed ancora una volta per il grande pgDesigner !!!!! :) :) :) :) :) :) :)
webmaster
Inviato il: 9/10/2006 11:37
Webmaster
Registrao: 1/3/2006
Da:
Messaggi: 251
Re: [HowTo] pgDesigner + Ubuntu-6.06.1-i386 (Italiano/English/Polski)
Grazie dei complimenti e del grande lavoro che hai fatto.
Metter? subito la tua guida negli HOWTO del sito.
giak
Inviato il: 11/10/2006 9:40
Matricola
Registrao: 11/3/2006
Da:
Messaggi: 16
Re: [HowTo] pgDesigner + Ubuntu-6.06.1-i386 (Italiano/English/Polski)
puoi inserire i repo per i vari pacchetti tipo gail o kdepim? hanno diverse dipendenze e installarli a mano e' da diventarci matti. grazie
pe3no
Inviato il: 11/10/2006 23:40
Matricola
Registrao: 5/8/2006
Da:
Messaggi: 17
Re: [HowTo] pgDesigner + Ubuntu-6.06.1-i386 (Italiano/English/Polski)
Citazione:

giak ha scritto:
puoi inserire i repo[...]

Ciao Giak,

ecco il sources.list - e' l'originale file creato durante l'installazione, tolti i caratteri "#":
#deb cdrom:[Ubuntu 6.06.1 _Dapper Drake_ - Release i386 (20060807)]/ dapper main restricted
deb http://it.archive.ubuntu.com/ubuntu/ dapper main restricted
deb-src http://it.archive.ubuntu.com/ubuntu/ dapper main restricted
deb http://it.archive.ubuntu.com/ubuntu/ dapper-updates main restricted
deb-src http://it.archive.ubuntu.com/ubuntu/ dapper-updates main restricted
deb http://it.archive.ubuntu.com/ubuntu/ dapper universe
deb-src http://it.archive.ubuntu.com/ubuntu/ dapper universe
deb http://it.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
deb-src http://it.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu dapper-security main restricted
deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted
deb http://security.ubuntu.com/ubuntu dapper-security universe
deb-src http://security.ubuntu.com/ubuntu dapper-security universe

Quale versione di Ubuntu hai installato?

Lo chiedo perche' ho rifatto l'installazione fresca di Ubuntu-6.06.1 - per essere sicuro di non aver fatto nessuno sbaglio nella guida.
Inoltre, l'ho eseguita per lingua italiana, per avere la certezza, che non c'e' nessuna differenza fra quella polacca ed italiana.
Sul mio PC ha funzionato al 100% - ho eseguito l'installazione pgDesigner usando questo HowTo, direttamente da www.ldrweb.net

In bocca al lupo per la Tua installazione :)

Cordiali saluti~~Piotrek~~pe3no.
giak
Inviato il: 12/10/2006 19:56
Matricola
Registrao: 11/3/2006
Da:
Messaggi: 16
Re: [HowTo] pgDesigner + Ubuntu-6.06.1-i386 (Italiano/English/Polski)
il problema sono le librerie kde che nn riesce a trovare!!! nella fattispecie kdepim-dev e tutte le sue dipendenze. Hai una qualche dritta? nei repo proposti non si trova
pe3no
Inviato il: 13/10/2006 1:11
Matricola
Registrao: 5/8/2006
Da:
Messaggi: 17
Re: [HowTo] pgDesigner + Ubuntu-6.06.1-i386 (Italiano/English/Polski)
Citazione:

giak ha scritto:
[...] kdepim-dev e tutte le sue dipendenze [...] nei repo proposti non si trova [...]


Giak, vorrei tanto aiutarTi, ma mi devi dare piu' informazioni e devono essere precise :)

DOMANDA 1: Quale e' la Tua versione di Ubuntu? (4.10, 5.04, 5.10, 6.06, 6.06.1, 6.10 beta ?)
DOMANDA 2: Mi puoi fare copy+paste del Tuo sources.list?

Se mi dai il link con l'immagine ISO, faccio il download, lo installo e faccio il test. Meglio di cosi'.... ?
Io, per la mia installazione ho usato http://nginyang.uvt.nl/dapper/ubuntu-6.06.1-dvd-i386.iso

Con le pochissime informazioni/supposizioni che ho, non sono in grado di aiutarTi ...

Per ricontrollare anchor'una volta se la guida e' senza errori, ho sostituito il sources.list con quello
che Ti avevo indicato e ripeto: questo e' il sources.list che si ottiene durante la normale installazione
di Ubuntu-6.06.1, togliendo poi tutti i caratteri "#" (tranne il CD - per costringerlo ad usare i repo www)

Allora ricominciamo daccapo

1. $ sudo gedit /etc/apt/sources.list
2. copiare + incollare il seguente testo:
#deb cdrom:[Ubuntu 6.06.1 _Dapper Drake_ - Release i386 (20060807)]/ dapper main restricted
deb http://it.archive.ubuntu.com/ubuntu/ dapper main restricted
deb-src http://it.archive.ubuntu.com/ubuntu/ dapper main restricted
deb http://it.archive.ubuntu.com/ubuntu/ dapper-updates main restricted
deb-src http://it.archive.ubuntu.com/ubuntu/ dapper-updates main restricted
deb http://it.archive.ubuntu.com/ubuntu/ dapper universe
deb-src http://it.archive.ubuntu.com/ubuntu/ dapper universe
deb http://it.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
deb-src http://it.archive.ubuntu.com/ubuntu/ dapper-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu dapper-security main restricted
deb-src http://security.ubuntu.com/ubuntu dapper-security main restricted
deb http://security.ubuntu.com/ubuntu dapper-security universe
deb-src http://security.ubuntu.com/ubuntu dapper-security universe

3. $ sudo apt-get update
4. $ sudo apt-cache search --names-only kdepim-dev
kdepim-dev - KDE Personal Information Management [development]

Giak, come vedi - il pacchetto c'e' nei repositori che Ti ho dato... installiamolo:

5. $ sudo apt-get install kdepim-dev
Non c'e' stato nessunissimo probleme, e sono state soddisfatte tutte le dipendenze
Continuo l'installazione del pgDesigner utilizzando la guida del nostro Forum (punti 5 - 18)
Non c'e' stato nessun problema - l'installazione pgDesigner e' finita con successo

Giak, ho bisogno delle Tue risposte - per poterTi aiutare

Cordiali saluti~~Piotrek~~pe3no.
giak
Inviato il: 31/10/2006 22:49
Matricola
Registrao: 11/3/2006
Da:
Messaggi: 16
Re: [HowTo] pgDesigner + Ubuntu-6.06.1-i386 (Italiano/English/Polski)
tutto installato e funzionante. di sicuro ci stavano dei problemi con i repo nonostante tutto sembrasse a posto. Installato gambas2 e pgdesigner sia su dapper che su edgy
pe3no
Inviato il: 1/11/2006 17:46
Matricola
Registrao: 5/8/2006
Da:
Messaggi: 17
Re: [HowTo] pgDesigner + Ubuntu-6.06.1-i386 (Italiano/English/Polski)
Citazione:

giak ha scritto:
tutto installato e funzionante[...]


Ciao Giak,
Sono contento che e' andata bene
Anche se, mi preoccupano quei problemi con i repositori, di qui scrivi
Sempre non riesco a capire, come mai io non gli ho mai avuti - se usiamo gli stessi repositori (???)

Aproposito, sei riuscito ad abilitare "pdf" e "firebird" in Gambas2 ?
Beh, non sono necessari per pgDesigner ma comunque - sarei curioso, come farlo...

Cordiali saluti~~Piotrek~~pe3no.
webmaster
Inviato il: 2/11/2006 10:28
Webmaster
Registrao: 1/3/2006
Da:
Messaggi: 251
Re: [HowTo] pgDesigner + Ubuntu-6.06.1-i386 (Italiano/English/Polski)
Anche in Fedora non sono riuscito ad installarli; per firebird, se non hai installato il package del database, non credo si possa fare alcunch?. Per pdf, non riesco a capire quale libreria vuole...
giak
Inviato il: 2/11/2006 23:03
Matricola
Registrao: 11/3/2006
Da:
Messaggi: 16
Re: [HowTo] pgDesigner + Ubuntu-6.06.1-i386 (Italiano/English/Polski)
si in effetti la cosa e' strana! i repo erano gli stessi che hai postato tu, ho fatto un copia e incolla e mi dava errore durante l'update dicendo che certe librerie non si riuscivano ad installare causa mancanza di dipendenze! mah, comunque poi dopo qualche giorno tutto ha funzionato. Per quello che riguarda pdf e firebird non me li ha installati, passi per firebird che non e' installato ma per il pdf non ho approfondito la questione comunque ho installato tutti i pdf in linux da evince ad acrobat e tutto tramite apt quindi anche tutte le dipendenze ma ancora non funzia. Scoccero' ancora le ba..e benoit e sentiamo che dice
(1) 2 »
Ad albero | I pi nuovi prima Discussione precedente | Discussione successiva | Inizio

Registrati per inviare messaggi
 
Copyright © 2006-2009 LDRWEB.net - consulting & software development - Powered by XOOPS 2.0 © 2001-2009 The XOOPS Project
Theme Design By James Morris